I'm always nervous when someone tries to change code just because they don't like the programming style (even though I've been guilty of it myself, my pet hate being bad indentation and alignment). It's led to bugs being introduced in the past. On first examination, though, this seems harmless enough.
On second examination, no. In "LAi_monsters.c", this...
Code:
int maxMonsters = 20 - LAi_numloginedcharacters;
... becomes this...
Code:
int maxMonsters = MAX_LOGINED_CHARACTERS_IN_LOCATION-12 - LAi_numloginedcharacters;
Fair enough. But then this...
Code:
if(maxMonsters > 8) maxMonsters = 8;
... becomes...
Code:
if(maxMonsters > MAX_LOGINED_CHARACTERS_IN_LOCATION-24) maxMonsters = MAX_LOGINED_CHARACTERS_IN_LOCATION-24;
I don't think this one should be dependent on "MAX_LOGINED_CHARACTERS_IN_LOCATION". That's already checked. This one is to prevent a small town location with only a couple of soldiers and hardly any permanent residents from being flooded with random walkers. In fact, it's the same line which I tried changing to use a different variable based on a location's attribute in the hope of boosting the walker population of large town locations, which didn't work because the limit based on "MAX_LOGINED_CHARACTERS_IN_LOCATION" had already capped the maximum number of walkers. So that one can stay at 8 for now, and if anyone does manage to raise "MAX_LOGINED_CHARACTERS_IN_LOCATION", we can try again to raise the walker population of large towns.
Meanwhile, in "quests_side.c", at case "mob part 2", this...
Code:
nummob = LAi_numloginedcharacters-30;
... becomes...
Code:
nummob = LAi_numloginedcharacters-MAX_LOGINED_CHARACTERS_IN_LOCATION-2;
You're subtracting "MAX_LOGINED_CHARACTERS_IN_LOCATION", then subtracting a further 2, which means you're subtracting 34, not 30. Easily enough fixed...
Code:
nummob = LAi_numloginedcharacters-(MAX_LOGINED_CHARACTERS_IN_LOCATION-2);
For clarity, I've put brackets round any other calculations based on "MAX_LOGINED_CHARACTERS_IN_LOCATION".